use strict;
my $str = 'this is a [sample] string
with [so.me] special ((words)). and he(r)e\'s [[another! one]] within double brack[ets.
let\'s finish] this.
#ver 1 - \\[(.*?)\\] - catch brackets, stop if nl between brackets
#ver 2 - \\[(.*?]*)\\] - same
#ver 3 - \\[([^]]+)\\] - same, but catch even if nl between brackets
#ver 4 - \\[([^\\[\\]]*)\\] - same
#ver 5 - (?<=\\[).+?(?=\\]) - catch inside the brackets, stops at nl
#ver 6 - (\\[(?:\\[??[^\\[]*?\\])) - same as #3
#ver 7 - (?<=\\[).*?(?=\\]) - same as # 5
#ver 8 - ([[][a-z \\s]+[]]) - catch only the first, w/ brackets
#ver 9 - (?:(?<=\\().+?(?=\\))|(?<=\\[).+?(?=\\])) - same as #5 but catch () as well';
my $regex = qr/(?:(?<=\().+?(?=\))|(?<=\[).+?(?=\]))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}