using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"XXX-\d{4}-(?!.*?[XYT])[A-Z]{4}";
string input = @"XXX-0000-AAAA is ok
XXX-0000-XAAA is not ok
XXX-0000-AAXA is not ok
XXX-0000-ABXX is not ok
XXX-0000-ABCT is not ok";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}