import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "XXX-\\d{4}-(?!.*?[XYT])[A-Z]{4}";
final String string = "XXX-0000-AAAA is ok\n"
+ "XXX-0000-XAAA is not ok\n\n"
+ "XXX-0000-AAXA is not ok\n"
+ "XXX-0000-ABXX is not ok\n"
+ "XXX-0000-ABCT is not ok";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}