$re = '/XXX-\d{4}-(?!.*?[XYT])[A-Z]{4}/';
$str = 'XXX-0000-AAAA is ok
XXX-0000-XAAA is not ok
XXX-0000-AAXA is not ok
XXX-0000-ABXX is not ok
XXX-0000-ABCT is not ok';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);