#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)From:[^@\r\n]+@(?>(\w{2,}\.)*)(?!(com|net|gov|edu|org)[^\w\.]?)"
Local $sString = "From: user.name@mail.com" & @CRLF & _
"From: username@sub.mail.com" & @CRLF & _
"From: username@sub.com" & @CRLF & _
"From: username@sub.io" & @CRLF & _
"From: username@sub.blurdy" & @CRLF & _
"From: username@sub.blub.example"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")