import re
regex = re.compile(r"From:[^@\r\n]+@(?>(\w{2,}\.)*)(?!(com|net|gov|edu|org)[^\w\.]?)", flags=re.MULTILINE)
test_str = ("From: user.name@mail.com\n"
"From: username@sub.mail.com\n"
"From: username@sub.com\n"
"From: username@sub.io\n"
"From: username@sub.blurdy\n"
"From: username@sub.blub.example")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")