$re = '/From:[^@\r\n]+@(?>(\w{2,}\.)*)(?!(com|net|gov|edu|org)[^\w\.]?)/m';
$str = 'From: user.name@mail.com
From: username@sub.mail.com
From: username@sub.com
From: username@sub.io
From: username@sub.blurdy
From: username@sub.blub.example';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);