#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z][^\d]{10,30}\.$"
Local $sString = "This is a good string." & @CRLF & _
"this, not so good." & @CRLF & _
"I'm an okay string." & @CRLF & _
"um, 3 things wrong here!" & @CRLF & _
"I'm. A. Good. String."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")