// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z][^\d]{10,30}\.$").unwrap();
let string = "This is a good string.
this, not so good.
I'm an okay string.
um, 3 things wrong here!
I'm. A. Good. String.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}