package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(features?|releases?|hotfix(es)?)\/[a-z\d]+([-/_.][a-z\d]+)*$`)
var str = `release/0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}