re = /^(features?|releases?|hotfix(es)?)\/[a-z\d]+([-\/_.][a-z\d]+)*$/m
str = 'release/0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end