$re = '`^(features?|releases?|hotfix(es)?)\/[a-z\d]+([-/_.][a-z\d]+)*$`m';
$str = 'release/0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);