package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)\A(.*?(\w+\s+){2}).*\Z`)
var str = `abc def ghi
jkl mno pqr
stu
vwx
yz
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}