$re = '/(?s)\A(.*?(\w+\s+){2}).*\Z/m';
$str = 'abc def ghi
jkl mno pqr
stu
vwx
yz
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);