// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)\A(.*?(\w+\s+){2}).*\Z").unwrap();
let string = "abc def ghi
jkl mno pqr
stu
vwx
yz
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}