# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^[[:blank:]]+|[[:blank:]]+$|([[:blank:]])[[:blank:]]+)/$2/gm;t' <<< " leading blanks
trailing blanks
leading and trailing
this has more spaces between words than needed
even blanks
odd blanks
"