use strict;
my $str = ' leading blanks
trailing blanks
leading and trailing
this has more spaces between words than needed
even blanks
odd blanks
';
my $regex = qr/(^[[:blank:]]+|[[:blank:]]+$|([[:blank:]])[[:blank:]]+)/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";