$re = '/(^[[:blank:]]+|[[:blank:]]+$|([[:blank:]])[[:blank:]]+)/m';
$str = ' leading blanks
trailing blanks
leading and trailing
this has more spaces between words than needed
even blanks
odd blanks
';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;