using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\..*?hello.*?\.";
string input = @"This is the 1st sentence. This is the 2nd. This is the 3rd, hello, world. This is the 4th.";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}