// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\..*?hello.*?\.").unwrap();
let string = "This is the 1st sentence. This is the 2nd. This is the 3rd, hello, world. This is the 4th.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}