$re = '/\..*?hello.*?\./i';
$str = 'This is the 1st sentence. This is the 2nd. This is the 3rd, hello, world. This is the 4th.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);