import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(.+)>([^<>]*)</\\1>";
final String string = " <Interceptor>\n"
+ " <AttackCoords>-80.03107887624853,25.351308629611</AttackCoords>\n"
+ " <Outcome>Interdiction</Outcome>\n"
+ " <Infiltrators>6</Infiltrators>\n"
+ " <Enforcer>Assured</Enforcer>\n"
+ " <ActionDate>2013-11-03</ActionDate>\n"
+ " <ActionTime>04:40:00</ActionTime>\n"
+ " <RecordNotes>Infiltrators: \n"
+ " Savanna Carrera,\n"
+ " Gregoria Farías,\n"
+ " Julina Abeyta,\n"
+ " Mariquita Alonso,\n"
+ " Urbano Briseño,\n"
+ " Victoro Montano </RecordNotes>\n"
+ " <NumEscaped>3</NumEscaped>\n"
+ " <LaunchCoords></LaunchCoords>\n"
+ " <AttackVessel>Raft</AttackVessel>\n"
+ " </Interceptor>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}