#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^## .*" & @CRLF & _
""
Local $sString = "# Automatisation RH : 5 Stratégies Révolutionnaires pour Transformer Votre Gestion des Talents en 2024" & @CRLF & _
"" & @CRLF & _
"## Introduction" & @CRLF & _
"- État des lieux de l'automatisation RH en 2024" & @CRLF & _
"- Enjeux et défis actuels des départements RH" & @CRLF & _
"- Présentation des bénéfices de l'automatisation" & @CRLF & _
"" & @CRLF & _
"## I. L'automatisation du recrutement" & @CRLF & _
"### 1.1 Solutions de présélection des candidats" & @CRLF & _
"- Intelligence artificielle dans le tri des CV" & @CRLF & _
"- Chatbots pour le premier contact" & @CRLF & _
"- Évaluation automatisée des compétences" & @CRLF & _
"" & @CRLF & _
"### 1.2 Optimisation du processus d'entretien" & @CRLF & _
"- Planification automatique des rendez-vous" & @CRLF & _
"- Outils d'évaluation digitaux" & @CRLF & _
"- Suivi automatisé des candidatures" & @CRLF & _
"" & @CRLF & _
"## II. Digitalisation de l'onboarding" & @CRLF & _
"### 2.1 Plateformes d'intégration digitale" & @CRLF & _
"- Portails RH automatisés" & @CRLF & _
"- Parcours d'intégration personnalisés" & @CRLF & _
"- Documentation numérique intelligente" & @CRLF & _
"" & @CRLF & _
"### 2.2 Suivi automatisé des nouveaux collaborateurs" & @CRLF & _
"- KPIs d'intégration" & @CRLF & _
"- Feedback automatique" & @CRLF & _
"- Programmes de formation digitaux" & @CRLF & _
"" & @CRLF & _
"## III. Gestion administrative automatisée" & @CRLF & _
"### 3.1 Dématérialisation des processus RH" & @CRLF & _
"- Gestion automatique des congés" & @CRLF & _
"- Système de paie intelligent" & @CRLF & _
"- Archivage numérique sécurisé" & @CRLF & _
"" & @CRLF & _
"### 3.2 Conformité et reporting" & @CRLF & _
"- Tableaux de bord automatisés" & @CRLF & _
"- Alertes réglementaires" & @CRLF & _
"- Génération de rapports RH" & @CRLF & _
"" & @CRLF & _
"## IV. Management de la performance" & @CRLF & _
"### 4.1 Outils d'évaluation continue" & @CRLF & _
"- Systèmes d'objectifs digitalisés" & @CRLF & _
"- Feedback en temps réel" & @CRLF & _
"- Analytics RH" & @CRLF & _
"" & @CRLF & _
"### 4.2 Développement des compétences" & @CRLF & _
"- Parcours de formation automatisés" & @CRLF & _
"- Recommandations personnalisées" & @CRLF & _
"- Suivi des certifications" & @CRLF & _
"" & @CRLF & _
"## V. Analyse prédictive des talents" & @CRLF & _
"### 5.1 Intelligence artificielle en RH" & @CRLF & _
"- Prédiction des turnovers" & @CRLF & _
"- Identification des hauts potentiels" & @CRLF & _
"- Planification prévisionnelle" & @CRLF & _
"" & @CRLF & _
"### 5.2 ROI et mesure d'impact" & @CRLF & _
"- Indicateurs clés de performance" & @CRLF & _
"- Analyse coûts-bénéfices" & @CRLF & _
"- Optimisation continue" & @CRLF & _
"" & @CRLF & _
"## Conclusion" & @CRLF & _
"- Synthèse des stratégies présentées" & @CRLF & _
"- Perspectives d'évolution" & @CRLF & _
"- Recommandations pour démarrer"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")