import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?![\\u0650\\u0660\\u064F])[\\u0600-\\u061E\\u0620-\\u065F\\u0670-\\u06ef]";
final String string = "\\u0602: \n"
+ "\\u0604: \n"
+ "\\u0650: ِ\n"
+ "\\u0660: ٠\n"
+ "\\u064F: ُ\n"
+ "\\u06ef: ۯ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}