const regex = new RegExp('(?![\\u0650\\u0660\\u064F])[\\u0600-\\u061E\\u0620-\\u065F\\u0670-\\u06ef]', 'gm')
const str = `\\u0602:
\\u0604:
\\u0650: ِ
\\u0660: ٠
\\u064F: ُ
\\u06ef: ۯ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}