re = /(?![\u0650\u0660\u064F])[\u0600-\u061E\u0620-\u065F\u0670-\u06ef]/m
str = '\\u0602:
\\u0604:
\\u0650: ِ
\\u0660: ٠
\\u064F: ُ
\\u06ef: ۯ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end