#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+\.\h+\K[^\n+-]*[^\s+-]"
Local $sString = "1. Medium Size +CA $33.00" & @CRLF & _
"2. Small Size -CA $4.00" & @CRLF & _
"3. Small Size-CA $4.00" & @CRLF & _
"" & @CRLF & _
"4. Small Size CA $4.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")