const regex = /^\d+\.\h+\K[^\n+-]*[^\s+-]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+\\.\\h+\\K[^\\n+-]*[^\\s+-]', 'gm')
const str = `1. Medium Size +CA \$33.00
2. Small Size -CA \$4.00
3. Small Size-CA \$4.00
4. Small Size CA \$4.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}