$re = '/^\d+\.\h+\K[^\n+-]*[^\s+-]/m';
$str = '1. Medium Size +CA $33.00
2. Small Size -CA $4.00
3. Small Size-CA $4.00
4. Small Size CA $4.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);