using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(Abstract|Base)[A-Z][a-zA-Z0-9]*$";
string input = @"AbstractClass
BaseClass
AbstractT
AbstractPerson";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}