package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(Abstract|Base)[A-Z][a-zA-Z0-9]*$`)
var str = `AbstractClass
BaseClass
AbstractT
AbstractPerson`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}