$re = '/(?<=[^=])=(?=[^=])(?=(?:[^\']*\'[^\']*\')*[^\']*$)/m';
$str = 'age=10 and address=\'a==c=d\' and age==100 and abc = 22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);