re = /(?<=[^=])=(?=[^=])(?=(?:[^\']*\'[^\']*\')*[^\']*$)/m
str = 'age=10 and address=\'a==c=d\' and age==100 and abc = 22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end