$re = '/[1-3][a-f]{5}_.*<IP>.*\tp\ta\ts\ts/m';
$str = '2abcde_123<IP>32131 p a s s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);