// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[1-3][a-f]{5}_.*<IP>.*\tp\ta\ts\ts").unwrap();
let string = "2abcde_123<IP>32131 p a s s";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}