package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:https?|ftp|smtp):\/\/)?(?:www\.)?(?:[\w-]+\.)+[a-z]+(?:\/[\w#-]+)*\/?$`)
var str = `https://cdn-myCdn.azure.net/send-to-home4/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}