re = /^(?:(?:https?|ftp|smtp):\/\/)?(?:www\.)?(?:[\w-]+\.)+[a-z]+(?:\/[\w#-]+)*\/?$/m
str = 'https://cdn-myCdn.azure.net/send-to-home4/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end