$re = '/^(?:(?:https?|ftp|smtp):\/\/)?(?:www\.)?(?:[\w-]+\.)+[a-z]+(?:\/[\w#-]+)*\/?$/m';
$str = 'https://cdn-myCdn.azure.net/send-to-home4/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);