import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bWord1 .*?\\b([0-9]{1,4}(?:[.,]\\d+)?) €";
final String string = "Word1 zerdezd : 1243 €\n\n"
+ "Word1 zerdezd 1243 €\n\n"
+ "But not on\n\n"
+ "Word1 zerdezd ezrozeu : 1243 €";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}