import re
regex = re.compile(r"\bWord1 .*?\b([0-9]{1,4}(?:[.,]\d+)?) €", flags=re.MULTILINE)
test_str = ("Word1 zerdezd : 1243 €\n\n"
"Word1 zerdezd 1243 €\n\n"
"But not on\n\n"
"Word1 zerdezd ezrozeu : 1243 €")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)