const regex = new RegExp('\\bWord1 .*?\\b([0-9]{1,4}(?:[.,]\\d+)?) €', 'gm')
const str = `Word1 zerdezd : 1243 €
Word1 zerdezd 1243 €
But not on
Word1 zerdezd ezrozeu : 1243 €`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);