using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z](?:[&.]?[A-Z])+\b";
string input = @"My name is STEVE. My friend works at (I.A.). Indian Army(IA). B&W also B&&W Also I...A";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}