// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[A-Z](?:[&.]?[A-Z])+\b").unwrap();
let string = "My name is STEVE. My friend works at (I.A.). Indian Army(IA). B&W also B&&W Also I...A";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}