package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z](?:[&.]?[A-Z])+\b`)
var str = `My name is STEVE. My friend works at (I.A.). Indian Army(IA). B&W also B&&W Also I...A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}