#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(Region: +(.*)[\r\n]Generated By: +(.*)[\r\n])"
Local $sString = "The Insurance Place Agency, LLC" & @CRLF & _
"2018/12/26 22:26:07" & @CRLF & _
"Region: null" & @CRLF & _
"Generated By: jmainer" & @CRLF & _
"New-HSAgency -AgencyName ''00018097''" & @CRLF & _
"New-HSAgencyGPO -AgencyName ''00018097''" & @CRLF & _
"New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''" & @CRLF & _
"The Insurance Place Agency, LLC" & @CRLF & _
"2018/12/26 22:26:07" & @CRLF & _
"Region: null" & @CRLF & _
"Generated By: jmain222er" & @CRLF & _
"New-HSAgency -AgencyName ''00018097''" & @CRLF & _
"New-HSAgencyGPO -AgencyName ''00018097''" & @CRLF & _
"New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''" & @CRLF & _
"The Insurance Place Agency, LLC" & @CRLF & _
"2018/12/26 22:26:07" & @CRLF & _
"Region: null" & @CRLF & _
"Generated By: jmainer" & @CRLF & _
"New-HSAgency -AgencyName ''00018097''" & @CRLF & _
"New-HSAgencyGPO -AgencyName ''00018097''" & @CRLF & _
"New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")