import Foundation
let pattern = #"(Region: +(.*)[\r\n]Generated By: +(.*)[\r\n])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmainer
New-HSAgency -AgencyName ''00018097''
New-HSAgencyGPO -AgencyName ''00018097''
New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''
The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmain222er
New-HSAgency -AgencyName ''00018097''
New-HSAgencyGPO -AgencyName ''00018097''
New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''
The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmainer
New-HSAgency -AgencyName ''00018097''
New-HSAgencyGPO -AgencyName ''00018097''
New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)