// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(Region: +(.*)[\r\n]Generated By: +(.*)[\r\n])").unwrap();
let string = "The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmainer
New-HSAgency -AgencyName ''00018097''
New-HSAgencyGPO -AgencyName ''00018097''
New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''
The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmain222er
New-HSAgency -AgencyName ''00018097''
New-HSAgencyGPO -AgencyName ''00018097''
New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''
The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmainer
New-HSAgency -AgencyName ''00018097''
New-HSAgencyGPO -AgencyName ''00018097''
New-HSUser -UserName ''18097_username'' -FirstName ''User'' -LastName ''Name'' -AgencyName ''00018097'' -Password ''LHdfzJYJOwH5''";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}