import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=some standard text. )(?:.*?)([^\\s]+@[^\\s]+)";
final String string = "Eg. 1: some standard text. Bugs Bunny bugs@gmail.com 0411111111 more standard text \n"
+ "Eg. 2: some standard text. Bugs The Bunny bugs@gmail.com 0411111111 more standard text\n"
+ "Eg. 3: some standard text. Bugs-Bunny bugs.bunny@gmail.com 0411111111 more standard text\n"
+ "Eg. 4: some standard text. Bugs bugs.bunny@gmail.com +6141 111 111 more standard text\n"
+ "Eg. 1: some standard text. Bugs o'Bunny bugs@gmail.com 0411111111 more standard text ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}