use strict;
my $str = 'Eg. 1: some standard text. Bugs Bunny bugs@gmail.com 0411111111 more standard text
Eg. 2: some standard text. Bugs The Bunny bugs@gmail.com 0411111111 more standard text
Eg. 3: some standard text. Bugs-Bunny bugs.bunny@gmail.com 0411111111 more standard text
Eg. 4: some standard text. Bugs bugs.bunny@gmail.com +6141 111 111 more standard text
Eg. 1: some standard text. Bugs o\'Bunny bugs@gmail.com 0411111111 more standard text ';
my $regex = qr/(?<=some standard text. )(?:.*?)([^\s]+@[^\s]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}