re = /(?<=some standard text. )(?:.*?)([^\s]+@[^\s]+)/m
str = 'Eg. 1: some standard text. Bugs Bunny bugs@gmail.com 0411111111 more standard text
Eg. 2: some standard text. Bugs The Bunny bugs@gmail.com 0411111111 more standard text
Eg. 3: some standard text. Bugs-Bunny bugs.bunny@gmail.com 0411111111 more standard text
Eg. 4: some standard text. Bugs bugs.bunny@gmail.com +6141 111 111 more standard text
Eg. 1: some standard text. Bugs o\'Bunny bugs@gmail.com 0411111111 more standard text '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end